Qubes - Whonix 14 to Whonix 15

Submitted by karen_m in Privacy (edited )

I just spent about 4 hours updating fedora, debian and whonix-gw, only to have whonix-ws crash during the "upgrade", and no terminals in whonix-ws working anymore to even attempt to fix it. https://www.whonix.org/wiki/Upgrading_Whonix_14_to_Whonix_15

Fedora from 29 to 30 works https://www.qubes-os.org/doc/template/fedora/upgrade-29-to-30/ and

Debian works here, but you need to substitute a few lines. Replace: any "jessie" with "stretch", "stretch" with "buster" and "qubes-r3.list" with "qubes-r4.list". (https://www.qubes-os.org/doc/template/debian/upgrade-8-to-9/)

For whonix, just do what the begining of the upgrading article suggests and just delete 14 and start fresh with 15. Because I now have to restart, i'm actually just going to start with a whole new qubes install because debian, fedora and whonix (by association) all had major distro changes last month. Hopefully this can save some other folks a big waste of time.

4

You must log in or register to comment.

There's nothing here…